ATI HD 4200 DXVA TESTS

By | August 22, 2010

Hi all,

Recently i bought a phenom x6 cpu and asus 785g board. My old graphic card was zotac gtx260+. In these days i didnt have so much time playing games so i sold zotac, and now im desperately trying to satisfy myself with onboard ati 4200 gpu bundled with 785 chipset.

So if only playing h264 coded videos this gpu should do the job and i can play smoothly videos like 1080p mkv or VC1 coded videos…..

But reality is harsh… When i try play my some of 1080p anime videos with dxva compatible i crashed to wall. Gosh…. MPC skipping so much frame no audio video sycnro.

So when i checked the video settings with media info:

cabac=1 / ref=4 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=6 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc=crf / mbtree=0 / crf=16.5 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:0.80

So whats the problem ? looks like reference frame isnt so high and h264 profile looks ok too. 4.1 is fine enough for playing dxva videos. So i think problem is hidden in the red words.

Next, i try to play another h264 coded 1080p video, this time a normal movie not an anime.

This is the media info for this movie:

cabac=1 / ref=4 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=9 / psy=1 / psy_rd=1.0:0.2 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=2 / deadzone=21,11 / chroma_qp_offset=-2 / threads=12 / nr=0 / decimate=0 / mbaff=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc_lookahead=0 / rc=2pass / mbtree=0 / bitrate=11793 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=50000 / vbv_bufsize=50000 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00

But this video can played smoothly there is no problem. Same resolution same codec even higher bitrate. But what is the difference ? Secod video encoded with dual pass, first one encoded with crf ? This is the problem or sometin else ?

Im not so sure, but problem is my onboard gpu isnt powerful enough to play all dxva compatible videos. I have proof too, check this screen shot

hd4200

my os is windows 7 ultimate, as u can see when i try play “Broken Blade 1- gg Fansub” my gpu under full load and still not enough to smooth playback.

Btw my hd4200 Default clock is 500mhz! i overclocked to 600mhz but still no good!

So im wondering what is the problem ? This hardware limit ? Or driver problem ?

Im waiting some comments from nvidia 9400 or 8400 users. They can play all the 1080p videos with dxva especially animes ? Is nvidia better than Ati for playing videos ? Or this problem is only my case ?

It looks like i have to buy a vga….. if i have to then i thnik i should go for gtx 460 or sometin else…

Whatsever take care!

2 thoughts on “ATI HD 4200 DXVA TESTS

  1. ilkertezcan

    Son Catalyst sürücüsünü yükleyip, MPC HC’nin en son SVN sürümünü denediniz mi? Sürekli gelişim halinde: http://www.xvidvideo.ru/media-player-classic-home-cinema-x86-x64/

    Splash’ın DxVA özelliği var (Radeon’un GPU desteğini kullanabiliyor): http://mirillis.com/en/products/splash.html

    Son VLC’ye de sadece vista/7’de çalışan gpu desteği eklenmiş.

    Benim anakart 780g (Radeon3200). DxVA’yı kullanabiliyorum. Yine CoreAVC’yi tercih ediyorum, akıcılık için. Yakında çıkacak 2.1 sürümünde DxVA desteği olacakmış.

    Reply
  2. kerem Post author

    Evet son sürücüleri ve mpc yi denedim ancak yinede sonuç değişmedi.

    Splash ı hiç deneme imkanım olmadı, hoş dayanamayıp gtx 460 aldım ve şimdi dxva sorunsuzca işliyor. Radeon 4200 ün takıldığı donduğu yada hiç açamadığı videoları gtx 460 kusursuzca açıp oynatabiliyor. Mpc sürümleri aynı olduğu halde üstelik.

    Tahminim x264@crf modda değişken bitrate ile dönüştürme olduğundan veri akşının anlık olarak arttığı yerlerde radeon gpu’sunda darboğaz oluştuğu yönünde.

    GpuZ ile sisteme baktığımda radeon’un sisteme 32bit(bunu doğrulamış değilim henüz) lik veriyolu ile bağlandığını görüyorum ve sistemimdeki ddr2 bellekleri kullanadığınıda düşünecek olursak bu tezim doğru olabilir.

    Ama dediğim gibi tamamen tahmini konuşuyorum.

    Zaten sorun dxva nın çalışmaması değil her video’da aynı başarımı gösterememesi.

    Her video’dan kastım ise yine dxva uyumluluğu taşıyan videolar.

    Yorumunuz ve verdiğiniz ilgiler içinde ayrıca teşekkür ederim.

    Splash ı deneyeceğim.

    Reply

Leave a Reply

Your email address will not be published.